« Назад

На сегодняшний день, использование L2TP/IPSec в качестве Client-to-Server VPN, является предпочитаемым на маршрутизаторах Mikrotik. Почему? Отвечаем. Большинство маршрутизаторов производства компании Mikrotik поддерживают аппаратное шифрование IPSec. А туннельный протокол L2TP, на текущий момент, поддерживается всеми современными операционными системами, такими как Windows, Android, MacOS. Ну и, кроме того, простота настройки, делает этот тип vpn-сервера универсальным стандартом для маршрутизатора Mikrotik.

Схема подключения выглядит следующим образом:

mikrotik1

Создаем пул адресов для клиентов. Размер пула выбирайте исходя из того, сколько у Вас будет удаленных клиентов:

1. Открываем меню IP.

2. Выбираем Pool.

3. В появившемся окне нажимаем кнопку Add (+).

4. В поле Name: прописываем название пула: pool-l2tp.

5. В поле Addresses: прописываем диапазон ip-адресов: 192.168.50.10-192.168.50.50.

6. Нажимаем кнопку OK для сохранения настроек.

mikrotik2

То же самое в командной строке:

>/ip pool

>add name=pool-l2tp ranges=192.168.50.10-192.168.50.50

 

Создаем профиль для клиентов:

1. Открываем меню PPP.

2. Переходим на вкладку Profiles.

3. Нажимаем кнопку Add (+).

mikrotik3

Настраиваем основные параметры:

1. В поле Name указываем название профиля.

2. В поле Local Address указываем локальный адрес vpn-сервера (в нашем случае — это будет 192.168.50.1).

3. В списке Remote Address выбираем созданный нами пул.

4. Значение Change TCP MSS меняем на yes.

5. Значение Use UPnP меняем на no.

6. Переходим на вкладку Protocols.

mikrotik4

1. Значение USE MPLS меняем на no.

2. Значение USE Compression меняем на no.

3. Значение USE Encryption меняем на no.

4. Переходим на вкладку Limits.

mikrotik5

1. Значение Only One меняем на yes.

2. Нажимаем кнопку OK для сохранения настроек.

mikrotik6

То же самое используя командную строку:

>/ppp profile

>add change-tcp-mss=yes local-address=192.168.50.1 name=l2tp-ipsec only-one=yes remote-address=pool-l2tp use-compression=no use-encryption=no use-mpls=no use-upnp=no

Создаем учетные записи пользователей, которые будут подключаться к vpn-серверу:

1. Переходим на вкладку Secrets.

2. Нажимаем кнопку Add (+).

mikrotik7

1. В поле Name указываем имя пользователя.

2. В поле Password вводим пароль пользователя.

3. В списке Service выбираем протокол l2tp.

4. В списке Profile выбираем созданный нами профиль l2tp-ipsec.

5. Нажимаем кнопку OK для сохранения настроек.

mikrotik8

В командной строке:

> /ppp secret

> add name=user1 password=test1 profile=l2tp-ipsec service=l2tp

Запускаем сервер L2TP:

1. Переходим на вкладку Interface.

2. Нажимаем кнопку L2TP Server.

3. Включаем сервер — галочка Enabled.

4. В списке Default Profile выбираем наш профиль.

5. Отключаем протокол mschap1.

6. Отключаем протокол pap.

7. В списке Use IPsec выбираем Yes.

8. В поле IPsec Secret указываем пароль к IPsec.

9. Нажимаем кнопку OK для сохранения настроек.

mikrotik10

В командной строке:

>/interface l2tp-server server

>set authentication=chap,mschap2 default-profile=l2tp-ipsec enabled=yes use-ipsec=yes ipsec-secret=secret

Если планируется использование vpn-клиентов на старых операционных системах, таких как Windows 7, необходимо выполнить несколько дополнительных действий, а именно:

1. Открываем меню IP.

2. Выбираем IPsec.

3. Переходим на вкладку Proposals и открываем настройки по-умолчанию.

4. В алгоритмах шифрования добавляем протокол 3des.

5. Нажимаем кнопку OK для сохранения настроек.

mikrotik11

mikrotik12

Переходим на закладку Profiles, открываем настройки по-умолчанию и выполняем то же самое:

mikrotik13

На этом настройка l2tp/IPsec на маршрутизаторе mikrotik окончена.

Компания «Инфотек» занимается комплексным обслуживанием коммерческих и бюджетных организаций и с удовольствием выполнит для Вас настройку L2tp/IPsec на оборудовании Mikrotik и еще много-много других работ. Обращайтесь.

Октябрь 2, 2020

Если у вас возникли вопросы

СВЯЖИТЕСЬ С НАМИ!

Оставьте свои данные и мы свяжемся
с вами ближайшее время